Amira not launching properly via HMH Ed

Incident Report for Amira Learning

Resolved

We're happy to share that the issue preventing Amira from launching via the HMH Ed platform has been resolved. Everything is now functioning as expected. We appreciate your patience and understanding, and if you experience any continued issues, please don’t hesitate to contact our support team.
Posted May 06, 2025 - 10:42 CDT

Investigating

We have received reports this morning that those districts who access Amira via the HMH Ed platform are not able to load Amira. The Amira application is working normally, but HMH Ed is not launching Amira correctly.

We are in touch with HMH directly to understand more. We will follow up with further updates.
Posted May 06, 2025 - 07:58 CDT
This incident affected: Application Status (Amira Learning Application).