Teachers having trouble launching Amira from HMH Ed

Incident Report for Amira Learning

Resolved

This incident has now been resolved. Thank you for your patience.
Posted Sep 17, 2025 - 15:26 CDT

Update

We are continuing to investigate this issue.
Posted Sep 17, 2025 - 09:45 CDT

Investigating

We have received reports that some teachers are unable to launch Amira via HMH Ed. Students and Administrators seem to be able to launch without issue.

We are investigating this situation with urgency and will follow up with further updates.
Posted Sep 17, 2025 - 09:43 CDT
This incident affected: Single Sign-on.