Assessment task repeating

Incident Report for Amira Learning

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 21:00 CST

Identified

Students taking an Assessment or Progress Monitor are currently being prompted to repeat the the first task of the assessment. Our engineers are aware of this issue and will be a implementing a fix after school hours. In the meantime, logging the student out and then back into the Assessment will resolve this issue and allow your student to proceed.
Posted Nov 17, 2025 - 10:43 CST
This incident affected: Application Status (Amira Learning Application).