Investigating Issues

Incident Report for Amira Learning

Resolved

This incident has been resolved. Thank you for your patience.
Posted Apr 08, 2025 - 11:07 CDT

Investigating

We are aware of an issue that was impacting some users of Amira earlier. Our engineers are now working to resolve the situation and expect site performance to improve. We are monitoring closely.
Posted Apr 08, 2025 - 10:52 CDT
This incident affected: AI Chatbot Status (Amira Learning Chatbot, Istation AI Chatbot), Website Status (Istation Website, Amira Learning Website), Application Status (Amira Learning Application, Istation Application, Story of America Application), and Rostering Services, Single Sign-on.