Reports loading slowly

Incident Report for Amira Learning

Resolved

After implementing our planned changes, we are seeing significantly improved performance. This incident is now resolved, but we will continue to monitor for any further issues.
Posted Sep 22, 2025 - 21:35 CDT

Update

Update: to avoid a potential mid-day operational disruption, we will be implementing changes this evening after the close of school that are expected to improve today's report-loading performance issues. Thank you for your patience.
Posted Sep 22, 2025 - 12:27 CDT

Identified

Reports for some users continue to load slowly. The issue has been identified and our engineers are working on a fix. We apologize for the inconvenience and will provide further updates.
Posted Sep 22, 2025 - 11:00 CDT

Investigating

Amira Learning reports are loading slowly for some teachers this morning. We are investigating and will respond shortly.
Posted Sep 22, 2025 - 09:47 CDT
This incident affected: Application Status (Amira Learning Application).